import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^5((0[0-9]|[3-5]\\d)|(92)) \\d{3} \\d{4}$";
final String string = "Turkcell\n\n"
+ "530 123 4567\n"
+ "531 123 4567\n"
+ "532 123 4567\n"
+ "533 123 4567\n"
+ "534 123 4567\n"
+ "535 123 4567\n"
+ "536 123 4567\n"
+ "537 123 4567\n"
+ "538 123 4567\n"
+ "539 123 4567\n\n"
+ "Türk Telekom Mobil\n\n"
+ "500 123 4567\n"
+ "501 123 4567\n"
+ "502 123 4567\n"
+ "503 123 4567\n"
+ "504 123 4567\n"
+ "505 123 4567\n"
+ "506 123 4567\n"
+ "507 123 4567\n"
+ "508 123 4567\n"
+ "509 123 4567\n\n"
+ "550 123 4567\n"
+ "551 123 4567\n"
+ "552 123 4567\n"
+ "553 123 4567\n"
+ "554 123 4567\n"
+ "555 123 4567\n"
+ "556 123 4567\n"
+ "557 123 4567\n"
+ "558 123 4567\n"
+ "559 123 4567\n\n"
+ "Vodafone\n\n"
+ "540 123 4567\n"
+ "541 123 4567\n"
+ "542 123 4567\n"
+ "543 123 4567\n"
+ "544 123 4567\n"
+ "545 123 4567\n"
+ "546 123 4567\n"
+ "547 123 4567\n"
+ "548 123 4567\n"
+ "549 123 4567\n\n"
+ "Globalstar\n\n"
+ "592 211 9999\n"
+ "592 212 0888\n\n"
+ "Teknomobil\n\n"
+ "592 113 0900\n"
+ "592 113 1900\n"
+ "592 113 2900\n"
+ "592 113 3900\n"
+ "592 113 4900\n"
+ "592 113 5900\n"
+ "592 113 6900\n"
+ "592 110 0900\n"
+ "592 110 1900\n"
+ "592 110 2900\n"
+ "592 110 3900\n"
+ "592 110 4900\n"
+ "592 110 5900\n"
+ "592 110 6900\n\n"
+ "TB Haberleşme\n\n"
+ "592 616 0900\n"
+ "592 616 1900\n"
+ "592 616 2900\n"
+ "592 616 3900\n"
+ "592 616 4900\n\n"
+ "Medium Telekom\n\n"
+ "592 216 9999";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}