package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)"(?<VoNo>[^"]*)";"(?<VoDt>[^"]*)";"(?<ValDt>[^"]*)";"(?<VoTp>[^"]*)";"(?<Txt>[^"]*)";"(?<DbAcNo>[^"]*)";"(?<DbTrnCl>[^"]*)";"(?<DbTxCd>[^"]*)";"(?<CrAcNo>[^"]*)";"(?<CrTrnCl>[^"]*)";"(?<CrTxCd>[^"]*)";"(?<Am>[^"]*)";"(?<InvoNo>[^"]*)";"(?<DueDt>[^"]*)";"(?<VatAm>[^"]*)";"(?<R1>[^"]*)";"(?<R2>[^"]*)";"(?<R7>[^"]*)";"(?<CID>[^"]*)";"(?<Txt2>[^"]*)";"(?<AGRef>[^"]*)";;`)
var str = `@Actor (=CustNo,SupNo,Nm,Ad1,Ad2,Ad3,PNo,PArea,Phone,Fax,MailAd,BsNo,BGiro,Ctry,Lang,Cur,CPmtTrm,SPmtTrm)
"10458";"0";"Vesterlandet GÂrd / D. Hansen";"Vesterlandet 226";"";"";"8407";"Sortland";"";"";"vesterlandetgaard@gmail.com";"926967878";"";"47";"47";"";"15";"15"
@IMPORT_METHOD(3)
@WaBnd (ValDt, SrcTp, Descr)
"20240326" "12" "Quick3 Import"
@WaVo (VoNo,VoDt,ValDt,VoTp,Txt,DbAcNo,DbTrnCl,DbTxCd,CrAcNo,CrTrnCl,CrTxCd,Am,InvoNo,DueDt,VatAm,R1,R2,R7,CID,Txt2,AGRef)
"100489";"20240326";"20240326";"11";"Utg.faktura";"10458";"0";"0";"0";"0";"0";"33818.00";"100489";"20240405";"";"";"";"";"001045801004890";"";"";;
"100489";"20240326";"20240326";"11";"Utg.faktura";"0";"0";"0";"7740";"0";"0";"0.50";"";"";"";"";"";"";"";"";"";;
"100489";"20240326";"20240326";"11";"Utg.faktura";"0";"0";"0";"3000";"0";"3";"30937.50";"";"";"";"1";"";"";"";"";"";;
"100489";"20240326";"20240326";"11";"Utg.faktura";"0";"0";"0";"3001";"0";"3";"2880.00";"";"";"";"1";"";"";"";"";"";;`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}