import re
regex = re.compile(r"\"(?<VoNo>[^\"]*)\";\"(?<VoDt>[^\"]*)\";\"(?<ValDt>[^\"]*)\";\"(?<VoTp>[^\"]*)\";\"(?<Txt>[^\"]*)\";\"(?<DbAcNo>[^\"]*)\";\"(?<DbTrnCl>[^\"]*)\";\"(?<DbTxCd>[^\"]*)\";\"(?<CrAcNo>[^\"]*)\";\"(?<CrTrnCl>[^\"]*)\";\"(?<CrTxCd>[^\"]*)\";\"(?<Am>[^\"]*)\";\"(?<InvoNo>[^\"]*)\";\"(?<DueDt>[^\"]*)\";\"(?<VatAm>[^\"]*)\";\"(?<R1>[^\"]*)\";\"(?<R2>[^\"]*)\";\"(?<R7>[^\"]*)\";\"(?<CID>[^\"]*)\";\"(?<Txt2>[^\"]*)\";\"(?<AGRef>[^\"]*)\";;", flags=re.MULTILINE)
test_str = ("@Actor (=CustNo,SupNo,Nm,Ad1,Ad2,Ad3,PNo,PArea,Phone,Fax,MailAd,BsNo,BGiro,Ctry,Lang,Cur,CPmtTrm,SPmtTrm)\n"
"\"10458\";\"0\";\"Vesterlandet GÂrd / D. Hansen\";\"Vesterlandet 226\";\"\";\"\";\"8407\";\"Sortland\";\"\";\"\";\"vesterlandetgaard@gmail.com\";\"926967878\";\"\";\"47\";\"47\";\"\";\"15\";\"15\"\n\n"
"@IMPORT_METHOD(3)\n\n"
"@WaBnd (ValDt, SrcTp, Descr)\n"
"\"20240326\" \"12\" \"Quick3 Import\"\n"
"@WaVo (VoNo,VoDt,ValDt,VoTp,Txt,DbAcNo,DbTrnCl,DbTxCd,CrAcNo,CrTrnCl,CrTxCd,Am,InvoNo,DueDt,VatAm,R1,R2,R7,CID,Txt2,AGRef)\n"
"\"100489\";\"20240326\";\"20240326\";\"11\";\"Utg.faktura\";\"10458\";\"0\";\"0\";\"0\";\"0\";\"0\";\"33818.00\";\"100489\";\"20240405\";\"\";\"\";\"\";\"\";\"001045801004890\";\"\";\"\";;\n"
"\"100489\";\"20240326\";\"20240326\";\"11\";\"Utg.faktura\";\"0\";\"0\";\"0\";\"7740\";\"0\";\"0\";\"0.50\";\"\";\"\";\"\";\"\";\"\";\"\";\"\";\"\";\"\";;\n"
"\"100489\";\"20240326\";\"20240326\";\"11\";\"Utg.faktura\";\"0\";\"0\";\"0\";\"3000\";\"0\";\"3\";\"30937.50\";\"\";\"\";\"\";\"1\";\"\";\"\";\"\";\"\";\"\";;\n"
"\"100489\";\"20240326\";\"20240326\";\"11\";\"Utg.faktura\";\"0\";\"0\";\"0\";\"3001\";\"0\";\"3\";\"2880.00\";\"\";\"\";\"\";\"1\";\"\";\"\";\"\";\"\";\"\";;")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")