package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\w*`)
var str = `MyNickName CSGOFLIME.NET
MyNickName HTTP://CSGOFLIME.NET
MyNickName http://www.CSGOFLIME.NET
MyNickName www.CSGOFLIME.NET`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}