import Foundation
let pattern = #"""
\b(
\w*
(?:
[fc]+(?:\W*[uoc]*)*k+|
di+(?:\W*c*)*k+|
c+(?:\W*[un]*)*t+|
s+(?:\W*[hia]*)*t+|
b+(?:\W*(?:[ich]|ea)*)*t+(?:\W*(?:[ich]|ea)*)*h+|
a[$s]|
arse
)
\w*
)\b
"""#
let regex = try! NSRegularExpression(pattern: pattern, options: .allowCommentsAndWhitespace)
let testString = #"""
fuck
f.cuk
fck
theres this fucking fuck you f.uck fkuck fuckfinhg
fuck fck
fock
fucccckkkkkkkkkkkkkkingggggg
sjns skndnsiofns
f
u
k
u
fffff.uuuuuu.kkkkkk
fucked shit idiot asshole
shit fuck
shat shitty
Other words...
dick dicking dickhead but not dock or duck
cock but not penis or phallus
cunt but not contain or cunilingus
bitch bitching but not batch or botching
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)