using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\w+\s*=\s*'([^']+)'";
string input = @"select name, count(1) from employees where status = 'Active' and role= 'Manager' group by name order by 1;";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}