// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\w+\s*=\s*'([^']+)'").unwrap();
let string = "select name, count(1) from employees where status = 'Active' and role= 'Manager' group by name order by 1;";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}