const regex = /^IT\d{2}[A-Z]{1}[0-9]{22}$/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^IT\\d{2}[A-Z]{1}[0-9]{22}$', '')
const str = `IT69G0306909492000010895135`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}