$re = '/^IT\d{2}[A-Z]{1}[0-9]{22}$/';
$str = 'IT69G0306909492000010895135';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);