import re
regex = re.compile(r"^IT\d{2}[A-Z]{1}[0-9]{22}$")
test_str = "IT69G0306909492000010895135"
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")