#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "<p>(\s| |<\s?br\s?\/>)*<\/p>"
Local $sString = "<p>ABI - Verbale incontro 10 Nov 2015</p>" & @CRLF & _
"" & @CRLF & _
"<p>Gestione Documentale</p>" & @CRLF & _
"" & @CRLF & _
"<p>Presenti:</p>" & @CRLF & _
"" & @CRLF & _
"<ul>" & @CRLF & _
" <li>Marco Acorte (Thaos)</li>" & @CRLF & _
" <li>Giampiero Sareceno (ABI) <g.saraceno@abi.it></li>" & @CRLF & _
" <li>Mariani Sergio (ABI) <s.mariani@abi.it></li>" & @CRLF & _
"</ul>" & @CRLF & _
"" & @CRLF & _
"<h2>Modifiche alla gestione formati html in modifica Scheda ODG</h2>" & @CRLF & _
"" & @CRLF & _
"<h3>Editor html</h3>" & @CRLF & _
"" & @CRLF & _
"<ul>" & @CRLF & _
" <li>I paragrafi all'interno del campo testo devono essere tutti giustificati</li>" & @CRLF & _
" <li>quando si fa copia e incolla da word vengono importati molti tag html con gli stili impostati dal modello di word dal quale è stato ricavato il documento sorgente, occorre eseguire una pulizia lasciando solo i tag html standard" & @CRLF & _
" <ul>" & @CRLF & _
" <li><strong><span style="font-weight: bold"></strong> deve essere equivalente a <strong><strong></strong></li>" & @CRLF & _
" <li><strong><span style="text-decoration: underline"> </strong>deve essere equivalente a <strong><u></strong></li>" & @CRLF & _
" <li>eliminare tag <strong><font></font></strong></li>" & @CRLF & _
" <li>eliminare paragrafi inutili es:<strong> <p style="stile1">&nbps;</p></strong></li>" & @CRLF & _
" <li>togliere gli stili dai <strong><p></strong> non vuoti.<br />" & @CRLF & _
" Es: <strong><p style="stile1">bla bla bla bla...</p></strong> deve diventare <strong><p>bla bla bla bla...</p></strong></li>" & @CRLF & _
" <li>togliere eventuali commenti in html.<br />" & @CRLF & _
" Es: <strong><!-- sadkfjhgakjdhfjkgkjasdhf →</strong></li>" & @CRLF & _
" </ul>" & @CRLF & _
" </li>" & @CRLF & _
" <li>Aggiungere tasto “mostra Caratteri speciali” (non stampabili es. invio, tab, spazio)</li>" & @CRLF & _
"</ul>" & @CRLF & _
"" & @CRLF & _
"<h3>Modello Word</h3>" & @CRLF & _
"" & @CRLF & _
"<ul>" & @CRLF & _
" <li>Paragrafo standard – aggiungere aggiungere spaziatura dopo ogni paragrafo</li>" & @CRLF & _
" <li>Punti elenco/numerato - aggiungere spaziatura dopo ogni singola voce</li>" & @CRLF & _
"</ul>" & @CRLF & _
"" & @CRLF & _
"<p> </p>" & @CRLF & _
"" & @CRLF & _
"<p> </p>" & @CRLF & _
"" & @CRLF & _
"<p></p>" & @CRLF & _
"" & @CRLF & _
"<p> </p> <!-- ([space]) -->" & @CRLF & _
"" & @CRLF & _
"<p> </p> <!-- (That's a [tab] character in there -->" & @CRLF & _
"" & @CRLF & _
"<p> </p>" & @CRLF & _
"" & @CRLF & _
"<p><br /></p>" & @CRLF & _
"" & @CRLF & _
"<p>" & @CRLF & _
" </p>" & @CRLF & _
"" & @CRLF & _
"<p>" & @CRLF & _
"<br /><br />" & @CRLF & _
" </p>" & @CRLF & _
"" & @CRLF & _
"<h2>Richieste nuove funzionalità</h2>" & @CRLF & _
"" & @CRLF & _
"<h3>Rilascia Schede bloccate</h3>" & @CRLF & _
"" & @CRLF & _
"<p>nuova funzione massiva "Rilascia Schede bloccate" da inserire nella pagina "Modifica Ordine del Giorno" (/ordinedelgiorno/AmmModificaODG.aspx) che dato un ODG cambi lo stato delle schede da BLOCCATO --> PRONTO.</p>" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")