use strict;
my $str = '<p>ABI - Verbale incontro 10 Nov 2015</p>
<p>Gestione Documentale</p>
<p>Presenti:</p>
<ul>
<li>Marco Acorte (Thaos)</li>
<li>Giampiero Sareceno (ABI) <g.saraceno@abi.it></li>
<li>Mariani Sergio (ABI) <s.mariani@abi.it></li>
</ul>
<h2>Modifiche alla gestione formati html in modifica Scheda ODG</h2>
<h3>Editor html</h3>
<ul>
<li>I paragrafi all'interno del campo testo devono essere tutti giustificati</li>
<li>quando si fa copia e incolla da word vengono importati molti tag html con gli stili impostati dal modello di word dal quale è stato ricavato il documento sorgente, occorre eseguire una pulizia lasciando solo i tag html standard
<ul>
<li><strong><span style="font-weight: bold"></strong> deve essere equivalente a <strong><strong></strong></li>
<li><strong><span style="text-decoration: underline"> </strong>deve essere equivalente a <strong><u></strong></li>
<li>eliminare tag <strong><font></font></strong></li>
<li>eliminare paragrafi inutili es:<strong> <p style="stile1">&nbps;</p></strong></li>
<li>togliere gli stili dai <strong><p></strong> non vuoti.<br />
Es: <strong><p style="stile1">bla bla bla bla...</p></strong> deve diventare <strong><p>bla bla bla bla...</p></strong></li>
<li>togliere eventuali commenti in html.<br />
Es: <strong><!-- sadkfjhgakjdhfjkgkjasdhf →</strong></li>
</ul>
</li>
<li>Aggiungere tasto “mostra Caratteri speciali” (non stampabili es. invio, tab, spazio)</li>
</ul>
<h3>Modello Word</h3>
<ul>
<li>Paragrafo standard – aggiungere aggiungere spaziatura dopo ogni paragrafo</li>
<li>Punti elenco/numerato - aggiungere spaziatura dopo ogni singola voce</li>
</ul>
<p> </p>
<p> </p>
<p></p>
<p> </p> <!-- ([space]) -->
<p> </p> <!-- (That\'s a [tab] character in there -->
<p> </p>
<p><br /></p>
<p>
</p>
<p>
<br /><br />
</p>
<h2>Richieste nuove funzionalità</h2>
<h3>Rilascia Schede bloccate</h3>
<p>nuova funzione massiva "Rilascia Schede bloccate" da inserire nella pagina "Modifica Ordine del Giorno" (/ordinedelgiorno/AmmModificaODG.aspx) che dato un ODG cambi lo stato delle schede da BLOCCATO --> PRONTO.</p>
';
my $regex = qr/<p>(\s| |<\s?br\s?\/>)*<\/p>/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}