import Foundation
let pattern = #"<p>(\s| |<\s?br\s?\/>)*<\/p>"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = ##"""
<p>ABI - Verbale incontro 10 Nov 2015</p>
<p>Gestione Documentale</p>
<p>Presenti:</p>
<ul>
<li>Marco Acorte (Thaos)</li>
<li>Giampiero Sareceno (ABI) <g.saraceno@abi.it></li>
<li>Mariani Sergio (ABI) <s.mariani@abi.it></li>
</ul>
<h2>Modifiche alla gestione formati html in modifica Scheda ODG</h2>
<h3>Editor html</h3>
<ul>
<li>I paragrafi all'interno del campo testo devono essere tutti giustificati</li>
<li>quando si fa copia e incolla da word vengono importati molti tag html con gli stili impostati dal modello di word dal quale è stato ricavato il documento sorgente, occorre eseguire una pulizia lasciando solo i tag html standard
<ul>
<li><strong><span style="font-weight: bold"></strong> deve essere equivalente a <strong><strong></strong></li>
<li><strong><span style="text-decoration: underline"> </strong>deve essere equivalente a <strong><u></strong></li>
<li>eliminare tag <strong><font></font></strong></li>
<li>eliminare paragrafi inutili es:<strong> <p style="stile1">&nbps;</p></strong></li>
<li>togliere gli stili dai <strong><p></strong> non vuoti.<br />
Es: <strong><p style="stile1">bla bla bla bla...</p></strong> deve diventare <strong><p>bla bla bla bla...</p></strong></li>
<li>togliere eventuali commenti in html.<br />
Es: <strong><!-- sadkfjhgakjdhfjkgkjasdhf →</strong></li>
</ul>
</li>
<li>Aggiungere tasto “mostra Caratteri speciali” (non stampabili es. invio, tab, spazio)</li>
</ul>
<h3>Modello Word</h3>
<ul>
<li>Paragrafo standard – aggiungere aggiungere spaziatura dopo ogni paragrafo</li>
<li>Punti elenco/numerato - aggiungere spaziatura dopo ogni singola voce</li>
</ul>
<p> </p>
<p> </p>
<p></p>
<p> </p> <!-- ([space]) -->
<p> </p> <!-- (That's a [tab] character in there -->
<p> </p>
<p><br /></p>
<p>
</p>
<p>
<br /><br />
</p>
<h2>Richieste nuove funzionalità</h2>
<h3>Rilascia Schede bloccate</h3>
<p>nuova funzione massiva "Rilascia Schede bloccate" da inserire nella pagina "Modifica Ordine del Giorno" (/ordinedelgiorno/AmmModificaODG.aspx) che dato un ODG cambi lo stato delle schede da BLOCCATO --> PRONTO.</p>
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)