use strict;
my $str = ' إيجاد رابط ضمن أفراد الفريق
العمل الجماعي';
my $regex = qr/((?:[\u0600-\u06ff])*(?:\u0639\u0645|\u0636)(?:[\u0600-\u06ff])*)/ip;
my $subst = '<i>$1</i>';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";