import re
regex = re.compile(r"((?:[\u0600-\u06ff])*(?:\u0639\u0645|\u0636)(?:[\u0600-\u06ff])*)", flags=re.IGNORECASE)
test_str = (" إيجاد رابط ضمن أفراد الفريق \n"
"العمل الجماعي")
subst = "<i>$1</i>"
result = regex.sub(subst, test_str)
if result:
print(result)