import Foundation
let pattern = #"((?:[\u0600-\u06ff])*(?:\u0639\u0645|\u0636)(?:[\u0600-\u06ff])*)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .caseInsensitive)
let testString = #"""
إيجاد رابط ضمن أفراد الفريق
العمل الجماعي
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"<i>$1</i>"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)