$re = '~^(?![^@]*?(?:\\\\\\\\\\\\|\b\\\\\b))([\w-\\\\\\\\/.]+)@((\[[0-9]{1,3}\.[0-9]{1,3}\.[0-9]{1,3}\.)|(([\w-]+\.)+))([a-zA-Z]{2,4}|[0-9]{1,3})(\]?)$~m';
$str = '
hello\\\\world@email.com
hello\\world@email.com
hello/world@gmil.com
hello@email.com
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);