import re
regex = re.compile(r"^(?![^@]*?(?:\\\\\\|\b\\\b))([\w-\\\\/.]+)@((\[[0-9]{1,3}\.[0-9]{1,3}\.[0-9]{1,3}\.)|(([\w-]+\.)+))([a-zA-Z]{2,4}|[0-9]{1,3})(\]?)$", flags=re.MULTILINE)
test_str = ("\n"
"hello\\\\world@email.com\n\n\n"
"hello\\world@email.com\n\n"
"hello/world@gmil.com\n\n"
"hello@email.com\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")