re = /^(?![^@]*?(?:\\\\\\|\b\\\b))([\w-\\\\\/.]+)@((\[[0-9]{1,3}\.[0-9]{1,3}\.[0-9]{1,3}\.)|(([\w-]+\.)+))([a-zA-Z]{2,4}|[0-9]{1,3})(\]?)$/m
str = '
hello\\\\world@email.com
hello\\world@email.com
hello/world@gmil.com
hello@email.com
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end