#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "((?(?!\.\d)\D)*)(\d*\.\d+|\d+)*((?(?<=\d).*))"
Local $sString = "adfgdfag3534561adgjkh2456246adg"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")