$re = '/((?(?!\.\d)\D)*)(\d*\.\d+|\d+)*((?(?<=\d).*))/';
$str = 'adfgdfag3534561adgjkh2456246adg';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);