using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"((?(?!\.\d)\D)*)(\d*\.\d+|\d+)*((?(?<=\d).*))";
string input = @"adfgdfag3534561adgjkh2456246adg";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}