#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "skuid: (\d+)"
Local $sString = "<script charset="gbk">" & @CRLF & _
" var pageConfig = {" & @CRLF & _
" compatible: true," & @CRLF & _
" product: {" & @CRLF & _
" modules: [" & @CRLF & _
" 'address'," & @CRLF & _
" 'prom'," & @CRLF & _
" 'colorsize'," & @CRLF & _
" 'buytype'," & @CRLF & _
" 'baitiao'," & @CRLF & _
" 'summary'," & @CRLF & _
" 'o2o'," & @CRLF & _
" 'buybtn'," & @CRLF & _
" 'track'," & @CRLF & _
" 'suits'," & @CRLF & _
" 'crumb'," & @CRLF & _
" 'fittings'," & @CRLF & _
" 'detail'," & @CRLF & _
" 'contact'," & @CRLF & _
" 'popbox'," & @CRLF & _
" 'preview'," & @CRLF & _
" 'info'," & @CRLF & _
" 'imcenter'," & @CRLF & _
" 'jdservice'," & @CRLF & _
" 'commitments'," & @CRLF & _
" 'gift'," & @CRLF & _
" 'popupCar'" & @CRLF & _
" ]," & @CRLF & _
" skuid: 11157027932, " & @CRLF & _
" cat: [670,671,672]," & @CRLF & _
" commentVersion:'888', " & @CRLF & _
" twoColumn: false, " & @CRLF & _
" isFeeType: true, " & @CRLF & _
" isCloseLoop:true, " & @CRLF & _
" isBookMvd4Baby: false, " & @CRLF & _
" addComments:true," & @CRLF & _
" mainSkuId:'10122299306', " & @CRLF & _
" foot: '//dx.3.cn/footer?type=common_config2'," & @CRLF & _
" shangjiazizhi: false }" & @CRLF & _
" };" & @CRLF & _
" try {" & @CRLF & _
" function is_sort_black_list() {" & @CRLF & _
" var jump_sort_list = {"6881":3,"1195":3,"10011":3,"6980":3,"12360":3};" & @CRLF & _
" if(jump_sort_list['670'] == 1 || jump_sort_list['671']==2 || jump_sort_list['672']==3) {" & @CRLF & _
" return false;" & @CRLF & _
" }" & @CRLF & _
" return false;" & @CRLF & _
" }" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"</script>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")