# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"skuid: (\d+)"
test_str = ("<script charset=\"gbk\">\n"
" var pageConfig = {\n"
" compatible: true,\n"
" product: {\n"
" modules: [\n"
" 'address',\n"
" 'prom',\n"
" 'colorsize',\n"
" 'buytype',\n"
" 'baitiao',\n"
" 'summary',\n"
" 'o2o',\n"
" 'buybtn',\n"
" 'track',\n"
" 'suits',\n"
" 'crumb',\n"
" 'fittings',\n"
" 'detail',\n"
" 'contact',\n"
" 'popbox',\n"
" 'preview',\n"
" 'info',\n"
" 'imcenter',\n"
" 'jdservice',\n"
" 'commitments',\n"
" 'gift',\n"
" 'popupCar'\n"
" ],\n"
" skuid: 11157027932, \n"
" cat: [670,671,672],\n"
" commentVersion:'888', \n"
" twoColumn: false, \n"
" isFeeType: true, \n"
" isCloseLoop:true, \n"
" isBookMvd4Baby: false, \n"
" addComments:true,\n"
" mainSkuId:'10122299306', \n"
" foot: '//dx.3.cn/footer?type=common_config2',\n"
" shangjiazizhi: false }\n"
" };\n"
" try {\n"
" function is_sort_black_list() {\n"
" var jump_sort_list = {\"6881\":3,\"1195\":3,\"10011\":3,\"6980\":3,\"12360\":3};\n"
" if(jump_sort_list['670'] == 1 || jump_sort_list['671']==2 || jump_sort_list['672']==3) {\n"
" return false;\n"
" }\n"
" return false;\n"
" }\n\n\n"
"</script>")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.