$re = '/skuid: (\d+)/';
$str = '<script charset="gbk">
var pageConfig = {
compatible: true,
product: {
modules: [
\'address\',
\'prom\',
\'colorsize\',
\'buytype\',
\'baitiao\',
\'summary\',
\'o2o\',
\'buybtn\',
\'track\',
\'suits\',
\'crumb\',
\'fittings\',
\'detail\',
\'contact\',
\'popbox\',
\'preview\',
\'info\',
\'imcenter\',
\'jdservice\',
\'commitments\',
\'gift\',
\'popupCar\'
],
skuid: 11157027932,
cat: [670,671,672],
commentVersion:\'888\',
twoColumn: false,
isFeeType: true,
isCloseLoop:true,
isBookMvd4Baby: false,
addComments:true,
mainSkuId:\'10122299306\',
foot: \'//dx.3.cn/footer?type=common_config2\',
shangjiazizhi: false }
};
try {
function is_sort_black_list() {
var jump_sort_list = {"6881":3,"1195":3,"10011":3,"6980":3,"12360":3};
if(jump_sort_list[\'670\'] == 1 || jump_sort_list[\'671\']==2 || jump_sort_list[\'672\']==3) {
return false;
}
return false;
}
</script>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);