import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\n"
+ " (\n"
+ " (?:\n"
+ " (?:\n"
+ " [a-z]+\n"
+ " (?:\n"
+ " \\.edges=\\((?1)\\)\n"
+ " )?\n"
+ " ),?\n"
+ " )+\n"
+ " )\n"
+ "$";
final String string = ".edges=(user)\n"
+ "false\n\n"
+ "edges=test\n"
+ "false\n\n"
+ "another:chars\n"
+ "false\n\n"
+ "pl-ouf\n"
+ "false\n\n"
+ "test\n"
+ "array('test')\n\n"
+ "lang,lang\n"
+ "array('lang', 'lang')\n\n"
+ "quest,ans\n"
+ "array('quest', 'ans')\n\n"
+ "q.edges=(a)\n"
+ "array('q' => array('a')))\n\n"
+ "e.edges=(lang,et.edges=(lang)),ans\n"
+ "array('e' => array('lang', 'et' => array('lang')), 'ans'))";
final Pattern pattern = Pattern.compile(regex, Pattern.UNICODE_CASE | Pattern.CASE_INSENSITIVE | Pattern.MULTILINE | Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}