$re = '/^
(
(?:
(?:
[a-z]+
(?:
\.edges=\((?1)\)
)?
),?
)+
)
$/uimx';
$str = '.edges=(user)
false
edges=test
false
another:chars
false
pl-ouf
false
test
array(\'test\')
lang,lang
array(\'lang\', \'lang\')
quest,ans
array(\'quest\', \'ans\')
q.edges=(a)
array(\'q\' => array(\'a\')))
e.edges=(lang,et.edges=(lang)),ans
array(\'e\' => array(\'lang\', \'et\' => array(\'lang\')), \'ans\'))';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);