use strict;
my $str = '.edges=(user)
false
edges=test
false
another:chars
false
pl-ouf
false
test
array(\'test\')
lang,lang
array(\'lang\', \'lang\')
quest,ans
array(\'quest\', \'ans\')
q.edges=(a)
array(\'q\' => array(\'a\')))
e.edges=(lang,et.edges=(lang)),ans
array(\'e\' => array(\'lang\', \'et\' => array(\'lang\')), \'ans\'))';
my $regex = qr/^
(
(?:
(?:
[a-z]+
(?:
\.edges=\((?1)\)
)?
),?
)+
)
$/uimxp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}