using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?![A-Za-z]+)\p{Cyrillic}+";
string input = @"{""employees"":[
{""firstName"":""John"", ""lastName"":""Doe""},
{""firstName"":""John"", ""lastName"":""Doe""},
{""firstName"":""Вилен"", ""lastName"":""Авангард""},
{""firstName"":""Станислав"", ""lastName"":""Андрей""}
]}";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}