re = /(?![A-Za-z]+)\p{Cyrillic}+/
str = '{"employees":[
{"firstName":"John", "lastName":"Doe"},
{"firstName":"John", "lastName":"Doe"},
{"firstName":"Вилен", "lastName":"Авангард"},
{"firstName":"Станислав", "lastName":"Андрей"}
]}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end