$re = '/(?![A-Za-z]+)\p{Cyrillic}+/';
$str = '{"employees":[
{"firstName":"John", "lastName":"Doe"},
{"firstName":"John", "lastName":"Doe"},
{"firstName":"Вилен", "lastName":"Авангард"},
{"firstName":"Станислав", "lastName":"Андрей"}
]}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);