#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[A-Za-z0-9 ]*[A-Z0-9][A-Za-z0-9 ]*$"
Local $sString = "Example" & @CRLF & _
"example" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"this is a test" & @CRLF & _
"" & @CRLF & _
"this is A test" & @CRLF & _
"" & @CRLF & _
"this is 4 test"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")