$re = '/^[A-Za-z0-9 ]*[A-Z0-9][A-Za-z0-9 ]*$/m';
$str = 'Example
example
this is a test
this is A test
this is 4 test';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);