re = /^[A-Za-z0-9 ]*[A-Z0-9][A-Za-z0-9 ]*$/m
str = 'Example
example
this is a test
this is A test
this is 4 test'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end