package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^([UL].+?)(?:/.*|)$`)
var str = `/data file FLG.dat
UAB-AB LRD1503 / reminder latches
LAB-AB LRD1503 / reminder latches
SAB-AB LRD1503 / reminder latches
LAB-AB LRD1503`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}