import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^([UL].+?)(?:/.*|)$";
final String string = "/data file FLG.dat\n"
+ "UAB-AB LRD1503 / reminder latches\n"
+ "LAB-AB LRD1503 / reminder latches\n"
+ "SAB-AB LRD1503 / reminder latches\n"
+ "LAB-AB LRD1503";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}