#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?=.*/pdf/)(?!.*help)(.+)"
Local $sString = "Shouldn't match: "/dealer/help/us/en/pdf/simple.pdf"" & @CRLF & _
"Should match: "/dealer/us/en/pdf/simple.pdf""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")