using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?=.*/pdf/)(?!.*help)(.+)";
string input = @"Shouldn't match: ""/dealer/help/us/en/pdf/simple.pdf""
Should match: ""/dealer/us/en/pdf/simple.pdf""";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}