re = /(?=.*\/pdf\/)(?!.*help)(.+)/
str = 'Shouldn\'t match: "/dealer/help/us/en/pdf/simple.pdf"
Should match: "/dealer/us/en/pdf/simple.pdf"'
# Print the match result
str.match(re) do |match|
puts match.to_s
end