package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mis)(<parent>.*?<child[ab]>).*?<child[ab]>`)
var str = `<Parent>
<ChildA>..</ChildA>
<ChildB>..</ChildB>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}