re = /(<parent>.*?<child[ab]>).*?<child[ab]>/mi
str = '<Parent>
<ChildA>..</ChildA>
<ChildB>..</ChildB>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end