$re = '/(<parent>.*?<child[ab]>).*?<child[ab]>/mis';
$str = '<Parent>
<ChildA>..</ChildA>
<ChildB>..</ChildB>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);