const regex = /\b(\d)\b/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b(\\d)\\b', 'g')
const str = `'1:2:3','10:20:30'`;
const subst = `0\1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);