$re = '/\b(\d)\b/';
$str = '\'1:2:3\',\'10:20:30\'';
$subst = "0\1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;