use strict;
my $str = '\'1:2:3\',\'10:20:30\'';
my $regex = qr/\b(\d)\b/p;
my $subst = '0\\1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";