import re
regex = re.compile(r"href=[\"']https?:\/\/(?<hostname>[^\/\"]+)[^>]+>(?:https?:\/\/)?(?!.*\k'hostname')", flags=re.IGNORECASE)
test_str = ("<A HREF=\"http://phishers.org/we_want_your_money.htm\">http://someLegitimateSite.com/somewhere </A>\n"
"<a href=\"https://example.com/subfolder\">example.com</a>\n"
"<a href=\"http://somebadsite.com\">https://somegoodsite.com</a>\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")