$re = '/foo(?!bar)/';
$str = 'foo and foobar are not the same
this one will match foo but not bar
and this one only has foobar in it';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);