import re
regex = re.compile(r"foo(?!bar)")
test_str = ("foo and foobar are not the same\n"
"this one will match foo but not bar\n"
"and this one only has foobar in it")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")