re = /foo(?!bar)/
str = 'foo and foobar are not the same
this one will match foo but not bar
and this one only has foobar in it'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end