#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\s*\K(?:^.*\S.*\r?\n)*?^.*[ ]चैव[ ]यत्[ ].*(?:\r?\n^.*\S.*)*"
Local $sString = "सत्कारमानपूजार्थं तपो दम्भेन चैव यत् ।" & @CRLF & _
"क्रियते तदिह प्रोक्तं राजसं चलमध्रुवम् ॥ 17.18॥" & @CRLF & _
"" & @CRLF & _
"दृष्ट्वा तु पाण्डवानीकं व्यूढं दुर्योधनस्तदा ।" & @CRLF & _
"आचार्यमुपसङ्गम्य राजा वचनमब्रवीत् ॥ १-२॥" & @CRLF & _
"" & @CRLF & _
"पश्यैतां पाण्डुपुत्राणामाचार्य महतीं चमूम् ।" & @CRLF & _
"व्यूढां द्रुपदपुत्रेण तव शिष्येण धीमता ॥ १-३॥" & @CRLF & _
"" & @CRLF & _
"अन्ये च बहवः शूरा मदर्थे त्यक्तजीविताः ।" & @CRLF & _
"नानाशस्त्रप्रहरणाः सर्वे युद्धविशारदाः ॥ १-९॥" & @CRLF & _
"" & @CRLF & _
"अपर्याप्तं तदस्माकं बलं भीष्माभिरक्षितम् ।" & @CRLF & _
"पर्याप्तं त्विदमेतेषां बलं भीमाभिरक्षितम् ॥ १-१०॥" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"सत्कारमानपूजार्थं तपो दम्भेन चैव यत् ।" & @CRLF & _
"क्रियते तदिह प्रोक्तं राजसं चलमध्रुवम् ॥ 17.18॥" & @CRLF & _
"hello world" & @CRLF & _
"" & @CRLF & _
" kk" & @CRLF & _
"kubhpkn" & @CRLF & _
"अभिसन्धाय तु फलं दम्भार्थमपि चैव यत् ।" & @CRLF & _
"इज्यते भरतश्रेष्ठ तं यज्ञं विद्धि राजसम् ॥ 17.12॥" & @CRLF & _
"" & @CRLF & _
"अयनेषु च सर्वेषु यथाभागमवस्थिताः ।" & @CRLF & _
"भीष्ममेवाभिरक्षन्तु भवन्तः सर्व एव हि ॥ १-११॥" & @CRLF & _
"" & @CRLF & _
" सत्कारमानपूजार्थं तपो दम्भेन चैव यत् ।" & @CRLF & _
" क्रियते तदिह प्रोक्तं राजसं चलमध्रुवम् ॥ 17.18॥" & @CRLF & _
"" & @CRLF & _
"सत्कारमानपूजार्थं तपो दम्भेन चैव यत् ।" & @CRLF & _
"क्रियते तदिह प्रोक्तं राजसं चलमध्रुवम् ॥ 17.18॥"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")